What’s Vulnerable › Vulnerabilities

CVE-2024-2446

Description

Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3 fail to limit the number of @-mentions processed per message, allowing an authenticated attacker to crash the client applications of other users via large, crafted messages.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 8.1.10, 9.2.6, 9.3.2, 9.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-2446 or the next vulnerability affects your stack