What’s Vulnerable › Vulnerabilities

CVE-2024-2447

Description

Mattermost versions 8.1.x before 8.1.11, 9.3.x before 9.3.3, 9.4.x before 9.4.4, and 9.5.x before 9.5.2 fail to authenticate the source of certain types of post actions, allowing an authenticated attacker to create posts as other users via a crafted post action.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 8.1.11, 9.3.3, 9.4.4, 9.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-2447 or the next vulnerability affects your stack