What’s Vulnerable › Vulnerabilities
CVE-2024-24474
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-20 · updated 2026-06-17
- Weakness: CWE-120
Description
QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI command when an expected non-DMA transfer length is less than the length of the available FIFO data. This occurs in esp_do_nodma in hw/scsi/esp.c because of an underflow of async_len.
Affected products
- QEMU: before 8.2.0 — fixed in 8.2.0
How to fix
Upgrade to a fixed version: QEMU 8.2.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/1047524396/5ce07b9d387095c276b1cd234ae5615e
- https://github.com/qemu/qemu/commit/77668e4b9bca03a856c27ba899a2513ddf52bb52
- https://gitlab.com/qemu-project/qemu/-/issues/1810
- https://security.netapp.com/advisory/ntap-20240510-0012/
- https://gist.github.com/1047524396/5ce07b9d387095c276b1cd234ae5615e
- https://github.com/qemu/qemu/commit/77668e4b9bca03a856c27ba899a2513ddf52bb52
- https://gitlab.com/qemu-project/qemu/-/issues/1810
- https://security.netapp.com/advisory/ntap-20240510-0012/
Get alerted when CVE-2024-24474 or the next vulnerability affects your stack