What’s Vulnerable › Vulnerabilities
CVE-2024-24478
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-21 · updated 2026-06-17
- Weakness: CWE-680
Description
An issue in Wireshark before 4.2.0 allows a remote attacker to cause a denial of service via the packet-bgp.c, dissect_bgp_open(tvbuff_t*tvb, proto_tree*tree, packet_info*pinfo), optlen components. NOTE: this is disputed by the vendor because neither release 4.2.0 nor any other release was affected.
Affected products
- Wireshark Foundation Wireshark: before 4.2.0 — fixed in 4.2.0
How to fix
Upgrade to a fixed version: Wireshark Foundation Wireshark 4.2.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/1047524396/e82c55147cd3cb62ef20cbdb0ec83694
- https://github.com/wireshark/wireshark/commit/80a4dc55f4d2fa33c2b36a99406500726d3faaef
- https://gitlab.com/wireshark/wireshark/-/issues/19347
- https://gist.github.com/1047524396/e82c55147cd3cb62ef20cbdb0ec83694
- https://github.com/wireshark/wireshark/commit/80a4dc55f4d2fa33c2b36a99406500726d3faaef
- https://gitlab.com/wireshark/wireshark/-/issues/19347
Get alerted when CVE-2024-24478 or the next vulnerability affects your stack