What’s Vulnerable › Vulnerabilities
CVE-2024-2450
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-15 · updated 2026-06-17
- Weakness: CWE-287
Description
Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3 fail to correctly verify account ownership when switching from email to SAML authentication, allowing an authenticated attacker to take over other user accounts via a crafted switch request under specific conditions.
Affected products
- Mattermost: from 8.1.0 before 8.1.10; from 9.2.0 before 9.2.6; from 9.3.0 before 9.3.2; from 9.4.0 before 9.4.3; 9.5.0 — fixed in 8.1.10, 9.2.6, 9.3.2, 9.4.3
How to fix
Upgrade to a fixed version: Mattermost 8.1.10, 9.2.6, 9.3.2, 9.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-2450 or the next vulnerability affects your stack