What’s Vulnerable › Vulnerabilities
CVE-2024-24549: Apache Tomcat: HTTP/2 header handling DoS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 23.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-20
Description
Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
Affected products
- Apache Tomcat: from 8.5.0 before 8.5.99; from 9.0.0 before 9.0.86; from 10.1.0 before 10.1.19; 11.0.0-milestone1, 11.0.0-milestone10, 11.0.0-milestone11, 11.0.0-milestone12, 11.0.0-milestone13, 11.0.0-milestone14 (+10) — fixed in 10.1.19, 8.5.99, 9.0.86
- Debian Linux: 10.0
- Fedoraproject Fedora: 39, 40
How to fix
Upgrade to a fixed version: Apache Tomcat 10.1.19, 8.5.99, 9.0.86. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/4c50rmomhbbsdgfjsgwlb51xdwfjdcvg
- http://www.openwall.com/lists/oss-security/2024/03/13/3
- https://lists.apache.org/thread/4c50rmomhbbsdgfjsgwlb51xdwfjdcvg
- https://lists.debian.org/debian-lts-announce/2024/04/msg00001.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3UWIS5MMGYDZBLJYT674ZI5AWFHDZ46B/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/736G4GPZWS2DSQO5WKXO3G6OMZKFEK55/
- https://security.netapp.com/advisory/ntap-20240402-0002/
Get alerted when CVE-2024-24549 or the next vulnerability affects your stack