What’s Vulnerable › Vulnerabilities
CVE-2024-24556: XSS in @urql/next
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
urql is a GraphQL client that exposes a set of helpers for several frameworks. The `@urql/next` package is vulnerable to XSS. To exploit this an attacker would need to ensure that the response returns `html` tags and that the web-application is using streamed responses (non-RSC). This vulnerability is due to improper escaping of html-like characters in the response-stream. To fix this vulnerability upgrade to version 1.1.1
Affected products
- urql-graphql urql: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: urql-graphql urql 1.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/urql-graphql/urql/commit/4b7011b70d5718728ff912d02a4dbdc7f703540d
- https://github.com/urql-graphql/urql/security/advisories/GHSA-qhjf-hm5j-335w
- https://github.com/urql-graphql/urql/commit/4b7011b70d5718728ff912d02a4dbdc7f703540d
- https://github.com/urql-graphql/urql/security/advisories/GHSA-qhjf-hm5j-335w
Get alerted when CVE-2024-24556 or the next vulnerability affects your stack