What’s Vulnerable › Vulnerabilities
CVE-2024-24574: phpMyFAQ vulnerable to stored XSS on attachments filename
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-05 · updated 2026-06-17
- Weakness: CWE-79
Description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Unsafe echo of filename in phpMyFAQ\phpmyfaq\admin\attachments.php leads to allowed execution of JavaScript code in client side (XSS). This vulnerability has been patched in version 3.2.5.
Affected products
- thorsten phpMyFAQ: before 3.2.5 — fixed in 3.2.5
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 3.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/commit/5479b4a4603cce71aa7eb4437f1c201153a1f1f5
- https://github.com/thorsten/phpMyFAQ/pull/2827
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-7m8g-fprr-47fx
- https://github.com/thorsten/phpMyFAQ/commit/5479b4a4603cce71aa7eb4437f1c201153a1f1f5
- https://github.com/thorsten/phpMyFAQ/pull/2827
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-7m8g-fprr-47fx
Get alerted when CVE-2024-24574 or the next vulnerability affects your stack