What’s Vulnerable › Vulnerabilities

CVE-2024-24575: libgit2 is vulnerable to a denial of service attack in `git_revparse_single`

Description

libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Using well-crafted inputs to `git_revparse_single` can cause the function to enter an infinite loop, potentially causing a Denial of Service attack in the calling application. The revparse function in `src/libgit2/revparse.c` uses a loop to parse the user-provided spec string. There is an edge-case during parsing that allows a bad actor to force the loop conditions to access arbitrary memory. Potentially, this could also leak memory if the extracted rev spec is reflected back to the attacker. As such, libgit2 versions before 1.4.0 are not affected. Users should upgrade to version 1.6.5 or 1.7.2.

Affected products

How to fix

Upgrade to a fixed version: libgit2 1.6.5, 1.7.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-24575 or the next vulnerability affects your stack