What’s Vulnerable › Vulnerabilities

CVE-2024-24680: Django denial-of-service attack in the intcomma template filter

Description

An issue was discovered in Django 3.2 before 3.2.24, 4.2 before 4.2.10, and Django 5.0 before 5.0.2. The intcomma template filter was subject to a potential denial-of-service attack when used with very long strings.

Affected products

How to fix

Upgrade to a fixed version: Django 3.2.24, 4.2.10, 5.0.2; Pypi Django 3.2.24, 4.2.10, 5.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-24680 or the next vulnerability affects your stack