What’s Vulnerable › Vulnerabilities
CVE-2024-24713: WordPress Auto Listings Plugin <= 2.6.5 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Auto Listings Auto Listings – Car Listings & Car Dealership Plugin for WordPress allows Stored XSS.This issue affects Auto Listings – Car Listings & Car Dealership Plugin for WordPress: from n/a through 2.6.5.
Affected products
- WP Auto Listings Auto Listings – Car Listings & Car Dealership Plugin for WordPress: before 2.6.6 — fixed in 2.6.6
How to fix
Upgrade to a fixed version: WP Auto Listings Auto Listings – Car Listings & Car Dealership Plugin for WordPress 2.6.6. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/auto-listings/wordpress-auto-listings-plugin-2-6-5-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/auto-listings/wordpress-auto-listings-plugin-2-6-5-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-24713 or the next vulnerability affects your stack