What’s Vulnerable › Vulnerabilities
CVE-2024-24746: Apache NimBLE: Denial of service in NimBLE Bluetooth stack
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-06 · updated 2026-06-17
- Weakness: CWE-835
Description
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache NimBLE. Specially crafted GATT operation can cause infinite loop in GATT server leading to denial of service in Bluetooth stack or device. This issue affects Apache NimBLE: through 1.6.0. Users are recommended to upgrade to version 1.7.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache NimBLE: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NimBLE 1.7.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/04/05/2
- https://github.com/apache/mynewt-nimble/commit/d42a0ebe6632bd0c318560e4293a522634f60594
- https://lists.apache.org/thread/bptkzc0o2ymjk8qqzqdmy39kcmh27078
- http://www.openwall.com/lists/oss-security/2024/04/05/2
- https://github.com/apache/mynewt-nimble/commit/d42a0ebe6632bd0c318560e4293a522634f60594
- https://lists.apache.org/thread/bptkzc0o2ymjk8qqzqdmy39kcmh27078
Get alerted when CVE-2024-24746 or the next vulnerability affects your stack