What’s Vulnerable › Vulnerabilities
CVE-2024-24753: Bref Multiple Value Headers Not Supported in ApiGatewayFormatV2
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-01 · updated 2026-06-17
- Weakness: CWE-436
Description
Bref enable serverless PHP on AWS Lambda. When Bref is used in combination with an API Gateway with the v2 format, it does not handle multiple values headers. If PHP generates a response with two headers having the same key but different values only the latest one is kept. If an application relies on multiple headers with the same key being set for security reasons, then Bref would lower the application security. For example, if an application sets multiple `Content-Security-Policy` headers, then Bref would just reflect the latest one. This vulnerability is patched in 2.1.13.
Affected products
- brefphp bref: before 2.1.13 — fixed in 2.1.13
How to fix
Upgrade to a fixed version: brefphp bref 2.1.13. Check the vendor advisory for mitigations.
References
- https://github.com/brefphp/bref/commit/f834027aaf88b3885f4aa8edf6944ae920daf2dc
- https://github.com/brefphp/bref/security/advisories/GHSA-99f9-gv72-fw9r
- https://github.com/brefphp/bref/commit/f834027aaf88b3885f4aa8edf6944ae920daf2dc
- https://github.com/brefphp/bref/security/advisories/GHSA-99f9-gv72-fw9r
Get alerted when CVE-2024-24753 or the next vulnerability affects your stack