What’s Vulnerable › Vulnerabilities
CVE-2024-24757: open-irs .env Exposure
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-02 · updated 2026-06-17
- Weakness: CWE-200
Description
open-irs is an issue response robot that reponds to issues in the installed repository. The `.env` file was accidentally uploaded when working with git actions. This problem is fixed in 1.0.1. Discontinuing all sensitive keys and turning into secrets.
Affected products
- Degamisu open-irs: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Degamisu open-irs 1.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/Degamisu/open-irs/security/advisories/GHSA-7r69-3vwh-wcfr
- https://github.com/Degamisu/open-irs/security/advisories/GHSA-7r69-3vwh-wcfr
Get alerted when CVE-2024-24757 or the next vulnerability affects your stack