What’s Vulnerable › Vulnerabilities
CVE-2024-24763: JumpServer Open Redirect Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-20 · updated 2026-06-17
- Weakness: CWE-601
Description
JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to version 3.10.0, attackers can exploit this vulnerability to construct malicious links, leading users to click on them, thereby facilitating phishing attacks or cross-site scripting attacks. Version 3.10.0 contains a patch for this issue. No known workarounds are available.
Affected products
- jumpserver: before 3.10.0 — fixed in 3.10.0
How to fix
Upgrade to a fixed version: jumpserver 3.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/jumpserver/jumpserver/releases/tag/v3.10.0
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-p2mq-cm25-g4m5
- https://github.com/jumpserver/jumpserver/releases/tag/v3.10.0
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-p2mq-cm25-g4m5
Get alerted when CVE-2024-24763 or the next vulnerability affects your stack