What’s Vulnerable › Vulnerabilities

CVE-2024-24772: Apache Superset: Improper Neutralisation of custom SQL on embedded context

Description

A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Superset 3.0.4, 3.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-24772 or the next vulnerability affects your stack