What’s Vulnerable › Vulnerabilities
CVE-2024-24773: Apache Superset: Improper validation of SQL statements allows for unauthorized access to data
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-28 · updated 2026-06-17
- Weakness: CWE-863
Description
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.
Affected products
- Apache Superset: before 3.0.4; from 3.1.0 before 3.1.1 — fixed in 3.0.4, 3.1.1
How to fix
Upgrade to a fixed version: Apache Superset 3.0.4, 3.1.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/28/4
- https://lists.apache.org/thread/h66fy6nj41cfx07zh7l552w6dmtjh501
- http://www.openwall.com/lists/oss-security/2024/02/28/4
- https://lists.apache.org/thread/h66fy6nj41cfx07zh7l552w6dmtjh501
Get alerted when CVE-2024-24773 or the next vulnerability affects your stack