What’s Vulnerable › Vulnerabilities
CVE-2024-24778: Apache StreamPipes: Resources Permission Escalation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-03 · updated 2026-06-17
- Weakness: CWE-269
Description
Improper privilege management in a REST interface allowed registered users to access unauthorized resources if the resource ID was know. This issue affects Apache StreamPipes: through 0.95.1. Users are recommended to upgrade to version 0.97.0 which fixes the issue.
Affected products
- Apache Software Foundation Apache StreamPipes: before 0.97.0 — fixed in 0.97.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache StreamPipes 0.97.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/j14w6wghlwwrgfgc6hoz9f94fwxtlgzh
- http://www.openwall.com/lists/oss-security/2025/03/03/1
Get alerted when CVE-2024-24778 or the next vulnerability affects your stack