What’s Vulnerable › Vulnerabilities
CVE-2024-24779: Apache Superset: Improper data authorization when creating a new dataset
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-28 · updated 2026-06-17
- Weakness: CWE-863
Description
Apache Superset with custom roles that include `can write on dataset` and without all data access permissions, allows for users to create virtual datasets to data they don't have access to. These users could then use those virtual datasets to get access to unauthorized data. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
Affected products
- Apache Superset: through 3.0.4; from 3.1.0 before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: Apache Superset 3.1.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/28/6
- https://lists.apache.org/thread/xzhz1m5bb9zxhyqgoy4q2d689b3zp4pq
- http://www.openwall.com/lists/oss-security/2024/02/28/6
- https://lists.apache.org/thread/xzhz1m5bb9zxhyqgoy4q2d689b3zp4pq
Get alerted when CVE-2024-24779 or the next vulnerability affects your stack