What’s Vulnerable › Vulnerabilities
CVE-2024-24796: WordPress Event Manager for WooCommerce Plugin <= 4.1.1 is vulnerable to PHP Object Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-12 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in MagePeople Team Event Manager and Tickets Selling Plugin for WooCommerce – WpEvently – WordPress Plugin.This issue affects Event Manager and Tickets Selling Plugin for WooCommerce – WpEvently – WordPress Plugin: from n/a through 4.1.1.
Affected products
- MagePeople Team Event Manager and Tickets Selling Plugin for WooCommerce: before 4.1.2 — fixed in 4.1.2
How to fix
Upgrade to a fixed version: MagePeople Team Event Manager and Tickets Selling Plugin for WooCommerce 4.1.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/mage-eventpress/wordpress-wpevently-plugin-4-1-1-php-object-injection-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/mage-eventpress/wordpress-wpevently-plugin-4-1-1-php-object-injection-vulnerability?_s_id=cve
Get alerted when CVE-2024-24796 or the next vulnerability affects your stack