What’s Vulnerable › Vulnerabilities
CVE-2024-24807: Sulu is vulnerable to HTML Injection via Autocomplete Suggestion
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-05 · updated 2026-06-17
- Weakness: CWE-80
Description
Sulu is a highly extensible open-source PHP content management system based on the Symfony framework. There is an issue when inputting HTML into the Tag name. The HTML is executed when the tag name is listed in the auto complete form. Only admin users can create tags so they are the only ones affected. The problem is patched with version(s) 2.4.16 and 2.5.12.
Affected products
- sulu: from 2.0.0 before 2.4.16; from 2.5.0 before 2.5.12 — fixed in 2.4.16, 2.5.12
How to fix
Upgrade to a fixed version: sulu 2.4.16, 2.5.12. Check the vendor advisory for mitigations.
References
- https://github.com/sulu/sulu/releases/tag/2.4.16
- https://github.com/sulu/sulu/releases/tag/2.5.12
- https://github.com/sulu/sulu/security/advisories/GHSA-gfrh-gwqc-63cv
- https://github.com/sulu/sulu/releases/tag/2.4.16
- https://github.com/sulu/sulu/releases/tag/2.5.12
- https://github.com/sulu/sulu/security/advisories/GHSA-gfrh-gwqc-63cv
Get alerted when CVE-2024-24807 or the next vulnerability affects your stack