What’s Vulnerable › Vulnerabilities
CVE-2024-24812: Frappe Authenticated Reflected Cross site scripting (XSS) in portal pages
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Frappe is a full-stack web application framework that uses Python and MariaDB on the server side and a tightly integrated client side library. Prior to versions 14.59.0 and 15.5.0, portal pages are susceptible to Cross-Site Scripting (XSS) which can be used to inject malicious JS code if user clicks on a malicious link. This vulnerability has been patched in versions 14.59.0 and 15.5.0. No known workarounds are available.
Affected products
- frappe: before 14.59.0; from 15.0.0 before 15.5.0 — fixed in 14.59.0, 15.5.0
How to fix
Upgrade to a fixed version: frappe 14.59.0, 15.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/releases/tag/v14.59.0
- https://github.com/frappe/frappe/releases/tag/v15.5.0
- https://github.com/frappe/frappe/security/advisories/GHSA-7p3m-h76m-hg9v
- https://github.com/frappe/frappe/releases/tag/v14.59.0
- https://github.com/frappe/frappe/releases/tag/v15.5.0
- https://github.com/frappe/frappe/security/advisories/GHSA-7p3m-h76m-hg9v
Get alerted when CVE-2024-24812 or the next vulnerability affects your stack