What’s Vulnerable › Vulnerabilities
CVE-2024-24816: Cross-site scripting (XSS) vulnerability in samples with enabled the preview feature
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-07 · updated 2026-06-17
- Weakness: CWE-79
Description
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability vulnerability has been discovered in versions prior to 4.24.0-lts in samples that use the `preview` feature. All integrators that use these samples in the production code can be affected. The vulnerability allows an attacker to execute JavaScript code by abusing the misconfigured preview feature. It affects all users using the CKEditor 4 at version < 4.24.0-lts with affected samples used in a production environment. A fix is available in version 4.24.0-lts.
Affected products
- ckeditor4: from 4.0 before 4.24.0 — fixed in 4.24.0
How to fix
Upgrade to a fixed version: ckeditor4 4.24.0. Check the vendor advisory for mitigations.
References
- https://ckeditor.com/cke4/addon/preview
- https://github.com/ckeditor/ckeditor4/commit/8ed1a3c93d0ae5f49f4ecff5738ab8a2972194cb
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-mw2c-vx6j-mg76
- https://ckeditor.com/cke4/addon/preview
- https://github.com/ckeditor/ckeditor4/commit/8ed1a3c93d0ae5f49f4ecff5738ab8a2972194cb
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-mw2c-vx6j-mg76
Get alerted when CVE-2024-24816 or the next vulnerability affects your stack