What’s Vulnerable › Vulnerabilities
CVE-2024-24822: Pimcore Admin Classic Bundle permissions are not getting checked when working with tags
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-07 · updated 2026-06-17
- Weakness: CWE-862
Description
Pimcore's Admin Classic Bundle provides a backend user interface for Pimcore. Prior to version 1.3.3, an attacker can create, delete etc. tags without having the permission to do so. A fix is available in version 1.3.3. As a workaround, one may apply the patch manually.
Affected products
- pimcore admin-ui-classic-bundle: before 1.3.3 — fixed in 1.3.3
How to fix
Upgrade to a fixed version: pimcore admin-ui-classic-bundle 1.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/admin-ui-classic-bundle/commit/24660b6d5ad9cbcb037a48d4309a6024e9adf251
- https://github.com/pimcore/admin-ui-classic-bundle/pull/412
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-3rfr-mpfj-2jwq
- https://github.com/pimcore/admin-ui-classic-bundle/commit/24660b6d5ad9cbcb037a48d4309a6024e9adf251
- https://github.com/pimcore/admin-ui-classic-bundle/pull/412
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-3rfr-mpfj-2jwq
Get alerted when CVE-2024-24822 or the next vulnerability affects your stack