What’s Vulnerable › Vulnerabilities
CVE-2024-24827: No rate limits on POST /uploads endpoint in Discourse
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-15 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is an open source platform for community discussion. Without a rate limit on the POST /uploads endpoint, it makes it easier for an attacker to carry out a DoS attack on the server since creating an upload can be a resource intensive process. Do note that the impact varies from site to site as various site settings like `max_image_size_kb`, `max_attachment_size_kb` and `max_image_megapixels` will determine the amount of resources used when creating an upload. The issue is patched in the latest stable, beta and tests-passed version of Discourse. Users are advised to upgrade. Users unable to upgrade should reduce `max_image_size_kb`, `max_attachment_size_kb` and `max_image_megapixels` as smaller uploads require less resources to process. Alternatively, `client_max_body_size` can be reduced in Nginx to prevent large uploads from reaching the server.
Affected products
- discourse: before 3.2.0; before 3.3.0 — fixed in 3.2.0, 3.3.0
How to fix
Upgrade to a fixed version: discourse 3.2.0, 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/003b80e62f97cd8c0114d6b9d3f93c10443e6fae
- https://github.com/discourse/discourse/security/advisories/GHSA-58vw-246g-fjj4
- https://github.com/discourse/discourse/commit/003b80e62f97cd8c0114d6b9d3f93c10443e6fae
- https://github.com/discourse/discourse/security/advisories/GHSA-58vw-246g-fjj4
Get alerted when CVE-2024-24827 or the next vulnerability affects your stack