What’s Vulnerable › Vulnerabilities
CVE-2024-24829: SSRF in Sentry via Phabricator integration
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-09 · updated 2026-06-17
- Weakness: CWE-918
Description
Sentry is an error tracking and performance monitoring platform. Sentry’s integration platform provides a way for external services to interact with Sentry. One of such integrations, the Phabricator integration (maintained by Sentry) with version <=24.1.1 contains a constrained SSRF vulnerability. An attacker could make Sentry send POST HTTP requests to arbitrary URLs (including internal IP addresses) by providing an unsanitized input to the Phabricator integration. However, the body payload is constrained to a specific format. If an attacker has access to a Sentry instance, this allows them to: 1. interact with internal network; 2. scan local/remote ports. This issue has been fixed in Sentry self-hosted release 24.1.2, and has already been mitigated on sentry.io on February 8. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- getsentry sentry: from 9.1.0 before 24.1.2 — fixed in 24.1.2
How to fix
Upgrade to a fixed version: getsentry sentry 24.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/self-hosted/releases/tag/24.1.2
- https://github.com/getsentry/sentry/pull/64882
- https://github.com/getsentry/sentry/security/advisories/GHSA-rqxh-fp9p-p98r
- https://github.com/getsentry/self-hosted/releases/tag/24.1.2
- https://github.com/getsentry/sentry/pull/64882
- https://github.com/getsentry/sentry/security/advisories/GHSA-rqxh-fp9p-p98r
Get alerted when CVE-2024-24829 or the next vulnerability affects your stack