What’s Vulnerable › Vulnerabilities
CVE-2024-24830: OpenObserve Privilege Escalation Vulnerability in Users API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-08 · updated 2026-06-17
- Weakness: CWE-269
Description
OpenObserve is a observability platform built specifically for logs, metrics, traces, analytics, designed to work at petabyte scale. A vulnerability has been identified in the "/api/{org_id}/users" endpoint. This vulnerability allows any authenticated regular user ('member') to add new users with elevated privileges, including the 'root' role, to an organization. This issue circumvents the intended security controls for role assignments. The vulnerability resides in the user creation process, where the payload does not validate the user roles. A regular user can manipulate the payload to assign root-level privileges. This vulnerability leads to Unauthorized Privilege Escalation and significantly compromises the application's role-based access control system. It allows unauthorized control over application resources and poses a risk to data security. All users, particularly those in administrative roles, are impacted. This issue has been addressed in release version 0.8.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- openobserve: before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: openobserve 0.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/openobserve/openobserve/security/advisories/GHSA-hfxx-g56f-8h5v
- https://github.com/openobserve/openobserve/security/advisories/GHSA-hfxx-g56f-8h5v
Get alerted when CVE-2024-24830 or the next vulnerability affects your stack