What’s Vulnerable › Vulnerabilities
CVE-2024-24882: WordPress LMS by Masteriyo plugin <= 1.7.2 - Privilege Escalation vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-17 · updated 2026-06-17
- Weakness: CWE-266
Description
Incorrect Privilege Assignment vulnerability in masteriyo Masteriyo - LMS learning-management-system.This issue affects Masteriyo - LMS: from n/a through <= 1.7.2.
Affected products
- LMS by Masteriyo: before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: LMS by Masteriyo 1.7.3. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/Wordpress/Plugin/learning-management-system/vulnerability/wordpress-lms-by-masteriyo-plugin-1-7-2-privilege-escalation-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/learning-management-system/wordpress-lms-by-masteriyo-plugin-1-7-2-privilege-escalation-vulnerability?_s_id=cve
Get alerted when CVE-2024-24882 or the next vulnerability affects your stack