What’s Vulnerable › Vulnerabilities
CVE-2024-2491: PowerPack Addons for Elementor <= 2.7.17 - Authenticated (Contributor+) Stored Cross-Site Scripting via *_html_tag*
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The PowerPack Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the *_html_tag* attribute of multiple widgets in all versions up to, and including, 2.7.17 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- ideaboxcreations PowerPack Addons for Elementor (Free Widgets, Extensions and Templates): before 2.7.18 — fixed in 2.7.18
How to fix
Upgrade to a fixed version: ideaboxcreations PowerPack Addons for Elementor (Free Widgets, Extensions and Templates) 2.7.18. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3053463/powerpack-lite-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/22c4b981-6135-4c44-aa68-f0d51704a68c?source=cve
- https://plugins.trac.wordpress.org/changeset/3053463/powerpack-lite-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/22c4b981-6135-4c44-aa68-f0d51704a68c?source=cve
Get alerted when CVE-2024-2491 or the next vulnerability affects your stack