What’s Vulnerable › Vulnerabilities
CVE-2024-24910: LocalprivilegeescalationinCheckPointZoneAlarmExtremeSecurityNextGen,IdentityAgentforWindows,andIdentityAgentforWindowsTerminalServerviacraftedDLLfile
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-732
Description
A local attacker can erscalate privileges on affected Check Point ZoneAlarm ExtremeSecurity NextGen, Identity Agent for Windows, and Identity Agent for Windows Terminal Server. To exploit this vulnerability, an attacker must first obtain the ability to execute local privileged code on the target system.
Affected products
- checkpoint Identity Agent: through r81.070.0000
- Check Point ZoneAlarm Extreme Security: before 4.2.712 — fixed in 4.2.712
How to fix
Upgrade to a fixed version: Check Point ZoneAlarm Extreme Security 4.2.712. Check the vendor advisory for mitigations.
References
- https://support.checkpoint.com/results/sk/sk182219
- https://support.checkpoint.com/results/sk/sk182219
Get alerted when CVE-2024-24910 or the next vulnerability affects your stack