What’s Vulnerable › Vulnerabilities
CVE-2024-25015: IBM MQ denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-01 · updated 2026-06-17
- Weakness: CWE-406
Description
IBM MQ 9.2 LTS, 9.3 LTS, and 9.3 CD Internet Pass-Thru could allow a remote user to cause a denial of service by sending HTTP requests that would consume all available resources. IBM X-Force ID: 281278.
Affected products
- IBM MQ: from 9.2.0.0 before 9.2.0.25; from 9.3.0 before 9.3.5; from 9.3.0.0 before 9.3.0.17 — fixed in 9.2.0.25, 9.3.0.17, 9.3.5
How to fix
Upgrade to a fixed version: IBM MQ 9.2.0.25, 9.3.0.17, 9.3.5. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/281278
- https://www.ibm.com/support/pages/node/7149583
- https://exchange.xforce.ibmcloud.com/vulnerabilities/281278
- https://www.ibm.com/support/pages/node/7149583
Get alerted when CVE-2024-25015 or the next vulnerability affects your stack