What’s Vulnerable › Vulnerabilities
CVE-2024-25016: IBM MQ denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-03 · updated 2026-06-17
- Weakness: CWE-20
Description
IBM MQ and IBM MQ Appliance 9.0, 9.1, 9.2, 9.3 LTS and 9.3 CD could allow a remote unauthenticated attacker to cause a denial of service due to incorrect buffering logic. IBM X-Force ID: 281279.
Affected products
- IBM MQ: from 9.0.0.0 before 9.0.0.23; from 9.1.0.0 before 9.1.0.20; from 9.2.0 before 9.2.0.22; from 9.3.0 before 9.3.0.16 — fixed in 9.0.0.23, 9.1.0.20, 9.2.0.22, 9.3.0.16
- IBM MQ Appliance: from 9.3.0.0 through 9.3.5.0
How to fix
Upgrade to a fixed version: IBM MQ 9.0.0.23, 9.1.0.20, 9.2.0.22, 9.3.0.16. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/281279
- https://www.ibm.com/support/pages/node/7123139
- https://exchange.xforce.ibmcloud.com/vulnerabilities/281279
- https://www.ibm.com/support/pages/node/7123139
Get alerted when CVE-2024-25016 or the next vulnerability affects your stack