What’s Vulnerable › Vulnerabilities
CVE-2024-25048: IBM MQ code execution
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-27 · updated 2026-06-17
- Weakness: CWE-122
Description
IBM MQ Appliance 9.3 CD and LTS are vulnerable to a heap-based buffer overflow, caused by improper bounds checking. A remote authenticated attacker could overflow a buffer and execute arbitrary code on the system or cause the server to crash. IBM X-Force ID: 283137.
Affected products
- IBM MQ Appliance: from 9.3.0.0 before 9.3.0.17; from 9.3.0.0 before 9.3.5 — fixed in 9.3.0.17, 9.3.5
How to fix
Upgrade to a fixed version: IBM MQ Appliance 9.3.0.17, 9.3.5. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/283137
- https://www.ibm.com/support/pages/node/7149481
- https://exchange.xforce.ibmcloud.com/vulnerabilities/283137
- https://www.ibm.com/support/pages/node/7149481
Get alerted when CVE-2024-25048 or the next vulnerability affects your stack