What’s Vulnerable › Vulnerabilities
CVE-2024-25062
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-04 · updated 2026-10-15
- Weakness: CWE-416
Description
An issue was discovered in libxml2 before 2.11.7 and 2.12.x before 2.12.5. When using the XML Reader interface with DTD validation and XInclude expansion enabled, processing crafted XML documents can lead to an xmlValidatePopElement use-after-free.
Affected products
- xmlsoft libxml2: before 2.11.7; from 2.12.0 before 2.12.5 — fixed in 2.11.7, 2.12.5
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.11.7, 2.12.5. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/libxml2/-/issues/604
- https://gitlab.gnome.org/GNOME/libxml2/-/tags
- https://gitlab.gnome.org/GNOME/libxml2/-/issues/604
- https://gitlab.gnome.org/GNOME/libxml2/-/tags
- https://lists.debian.org/debian-lts-announce/2025/02/msg00028.html
- https://security.netapp.com/advisory/ntap-20241018-0009/
- https://cert-portal.siemens.com/productcert/html/ssa-784301.html
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
Get alerted when CVE-2024-25062 or the next vulnerability affects your stack