What’s Vulnerable › Vulnerabilities
CVE-2024-25078
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-15 · updated 2026-06-17
- Weakness: CWE-822
Description
A memory corruption vulnerability in StorageSecurityCommandDxe in Insyde InsydeH2O before kernel 5.2: IB19130163 in 05.29.07, kernel 5.3: IB19130163 in 05.38.07, kernel 5.4: IB19130163 in 05.46.07, kernel 5.5: IB19130163 in 05.54.07, and kernel 5.6: IB19130163 in 05.61.07 could lead to escalating privileges in SMM.
Affected products
- Insyde Kernel: from 5.2 before 5.29.07; from 5.3 before 5.38.07; from 5.4 before 5.46.07; from 5.5 before 5.54.07; from 5.6 before 5.61.07 — fixed in 5.29.07, 5.38.07, 5.46.07, 5.54.07, 5.61.07
How to fix
Upgrade to a fixed version: Insyde Kernel 5.29.07, 5.38.07, 5.46.07, 5.54.07. Check the vendor advisory for mitigations.
References
- https://www.insyde.com/security-pledge
- https://www.insyde.com/security-pledge/SA-2024001
- https://www.insyde.com/security-pledge
- https://www.insyde.com/security-pledge/SA-2024001
Get alerted when CVE-2024-25078 or the next vulnerability affects your stack