What’s Vulnerable › Vulnerabilities
CVE-2024-2509: Gutenberg Blocks by Kadence Blocks < 3.2.26 - Contributor+ Stored XSS
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gutenberg Blocks by Kadence Blocks WordPress plugin before 3.2.26 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- stellarwp Kadence Blocks — Page Builder Toolkit for Gutenberg Editor: before 3.2.26 — fixed in 3.2.26
How to fix
Upgrade to a fixed version: stellarwp Kadence Blocks — Page Builder Toolkit for Gutenberg Editor 3.2.26. Check the vendor advisory for mitigations.
References
- https://research.cleantalk.org/cve-2024-2509/
- https://wpscan.com/vulnerability/dec4a632-e04b-4fdd-86e4-48304b892a4f/
- https://research.cleantalk.org/cve-2024-2509/
- https://wpscan.com/vulnerability/dec4a632-e04b-4fdd-86e4-48304b892a4f/
Get alerted when CVE-2024-2509 or the next vulnerability affects your stack