What’s Vulnerable › Vulnerabilities
CVE-2024-25090: Apache Roller: Insufficient input validation for some user profile and bookmark fields when Roller in untested-users mode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-26 · updated 2026-06-17
- Weakness: CWE-20
Description
Insufficient input validation and sanitation in Profile name & screenname, Bookmark name & description and blogroll name features in all versions of Apache Roller on all platforms allows an authenticated user to perform an XSS attack. Mitigation: if you do not have Roller configured for untrusted users, then you need to do nothing because you trust your users to author raw HTML and other web content. If you are running with untrusted users then you should upgrade to Roller 6.1.3. This issue affects Apache Roller: from 5.0.0 before 6.1.3. Users are recommended to upgrade to version 6.1.3, which fixes the issue.
Affected products
- Apache Software Foundation Apache Roller: from 5.0.0 before 6.1.3 — fixed in 6.1.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Roller 6.1.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/lb50jqyxwf8jrfpydl6dc5zpqtpgrrwd
- http://www.openwall.com/lists/oss-security/2024/07/25/2
- https://lists.apache.org/thread/lb50jqyxwf8jrfpydl6dc5zpqtpgrrwd
Get alerted when CVE-2024-25090 or the next vulnerability affects your stack