What’s Vulnerable › Vulnerabilities
CVE-2024-25093: WordPress GD Rating System Plugin <= 3.5 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Milan Petrovic GD Rating System allows Stored XSS.This issue affects GD Rating System: from n/a through 3.5.
Affected products
- Milan Petrovic GD Rating System: before 3.5.1 — fixed in 3.5.1
How to fix
Upgrade to a fixed version: Milan Petrovic GD Rating System 3.5.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/gd-rating-system/wordpress-gd-rating-system-plugin-3-5-unauthenticated-stored-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/gd-rating-system/wordpress-gd-rating-system-plugin-3-5-unauthenticated-stored-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-25093 or the next vulnerability affects your stack