What’s Vulnerable › Vulnerabilities
CVE-2024-25108: Insufficient authorization allowing elevated access to resources in pixelfed
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-12 · updated 2026-06-17
- Weakness: CWE-280
Description
Pixelfed is an open source photo sharing platform. When processing requests authorization was improperly and insufficiently checked, allowing attackers to access far more functionality than users intended, including to the administrative and moderator functionality of the Pixelfed server. This vulnerability affects every version of Pixelfed between v0.10.4 and v0.11.9, inclusive. A proof of concept of this vulnerability exists. This vulnerability affects every local user of a Pixelfed server, and can potentially affect the servers' ability to federate. Some user interaction is required to setup the conditions to be able to exercise the vulnerability, but the attacker could conduct this attack time-delayed manner, where user interaction is not actively required. This vulnerability has been addressed in version 0.11.11. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- pixelfed: from 0.10.4 before 0.11.11 — fixed in 0.11.11
How to fix
Upgrade to a fixed version: pixelfed 0.11.11. Check the vendor advisory for mitigations.
References
- https://github.com/pixelfed/pixelfed/commit/7e47d6dccb0393a2e95c42813c562c854882b037
- https://github.com/pixelfed/pixelfed/security/advisories/GHSA-gccq-h3xj-jgvf
- https://github.com/pixelfed/pixelfed/commit/7e47d6dccb0393a2e95c42813c562c854882b037
- https://github.com/pixelfed/pixelfed/security/advisories/GHSA-gccq-h3xj-jgvf
Get alerted when CVE-2024-25108 or the next vulnerability affects your stack