What’s Vulnerable › Vulnerabilities
CVE-2024-25111: SQUID-2024:1 Denial of Service in HTTP Chunked Decoding
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 65.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-06 · updated 2026-06-17
- Weakness: CWE-674
Description
Squid is a web proxy cache. Starting in version 3.5.27 and prior to version 6.8, Squid may be vulnerable to a Denial of Service attack against HTTP Chunked decoder due to an uncontrolled recursion bug. This problem allows a remote attacker to cause Denial of Service when sending a crafted, chunked, encoded HTTP Message. This bug is fixed in Squid version 6.8. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. There is no workaround for this issue.
Affected products
- Fedoraproject Fedora: 38, 39
- NetApp Bluexp: all versions
- Squid: from 3.5.27 before 6.8 — fixed in 6.8
How to fix
Upgrade to a fixed version: Squid 6.8. Check the vendor advisory for mitigations.
References
- http://www.squid-cache.org/Versions/v6/SQUID-2024_1.patch
- https://github.com/squid-cache/squid/security/advisories/GHSA-72c2-c3wm-8qxc
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/7R4KPSO3MQT3KAOZV7LC2GG3CYMCGK7H/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XWQHRDRHDM5PQTU6BHH4C5KGL37X6TVI/
- https://security.netapp.com/advisory/ntap-20240605-0001/
- http://www.squid-cache.org/Versions/v6/SQUID-2024_1.patch
- https://github.com/squid-cache/squid/security/advisories/GHSA-72c2-c3wm-8qxc
- https://lists.debian.org/debian-lts-announce/2025/03/msg00009.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/7R4KPSO3MQT3KAOZV7LC2GG3CYMCGK7H/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XWQHRDRHDM5PQTU6BHH4C5KGL37X6TVI/
- https://security.netapp.com/advisory/ntap-20240605-0001/
Get alerted when CVE-2024-25111 or the next vulnerability affects your stack