What’s Vulnerable › Vulnerabilities
CVE-2024-25112: Denial of service due to unbounded recursion in QuickTimeVideo::multipleEntriesDecoder in Exiv2
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-12 · updated 2026-06-17
- Weakness: CWE-400
Description
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A denial-of-service was found in Exiv2 version v0.28.1: an unbounded recursion can cause Exiv2 to crash by exhausting the stack. The vulnerable function, `QuickTimeVideo::multipleEntriesDecoder`, was new in v0.28.0, so Exiv2 versions before v0.28 are _not_ affected. The denial-of-service is triggered when Exiv2 is used to read the metadata of a crafted video file. This bug is fixed in version v0.28.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- exiv2: 0.28.0, 0.28.1
References
- https://github.com/Exiv2/exiv2/pull/2337
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-crmj-qh74-2r36
- https://github.com/Exiv2/exiv2/pull/2337
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-crmj-qh74-2r36
Get alerted when CVE-2024-25112 or the next vulnerability affects your stack