What’s Vulnerable › Vulnerabilities
CVE-2024-25141: Apache Airflow Mongo Provider: Certificate validation isn't respected even if SSL is enabled for apache-airflow-providers-mongo
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-20 · updated 2026-06-17
- Weakness: CWE-295
Description
When ssl was enabled for Mongo Hook, default settings included "allow_insecure" which caused that certificates were not validated. This was unexpected and undocumented. Users are recommended to upgrade to version 4.0.0, which fixes this issue.
Affected products
- Apache Software Foundation Apache Airflow Mongo Provider: from 1.0.0 before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Mongo Provider 4.0.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/20/5
- https://github.com/apache/airflow/pull/37214
- https://lists.apache.org/thread/sqgbfqngjmn45ommmrgj7hvs7fgspsgm
- http://www.openwall.com/lists/oss-security/2024/02/20/5
- https://github.com/apache/airflow/pull/37214
- https://lists.apache.org/thread/sqgbfqngjmn45ommmrgj7hvs7fgspsgm
Get alerted when CVE-2024-25141 or the next vulnerability affects your stack