What’s Vulnerable › Vulnerabilities

CVE-2024-25144

Description

The IFrame widget in Liferay Portal 7.2.0 through 7.4.3.26, and older unsupported versions, and Liferay DXP 7.4 before update 27, 7.3 before update 6, 7.2 before fix pack 19, and older unsupported versions does not check the URL of the IFrame, which allows remote authenticated users to cause a denial-of-service (DoS) via a self referencing IFrame.

Affected products

How to fix

Upgrade to a fixed version: Liferay Portal 7.4.3.26. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-25144 or the next vulnerability affects your stack