What’s Vulnerable › Vulnerabilities
CVE-2024-25152
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Stored cross-site scripting (XSS) vulnerability in Message Board widget in Liferay Portal 7.2.0 through 7.4.2, and older unsupported versions, and Liferay DXP 7.3 before service pack 3, 7.2 before fix pack 17, and older unsupported versions allows remote authenticated users to inject arbitrary web script or HTML via the filename of an attachment.
Affected products
- Liferay Digital Experience Platform: before 7.2; 7.2, 7.2-fix_pack_1, 7.2-fix_pack_10, 7.2-fix_pack_11, 7.2-fix_pack_12, 7.2-fix_pack_13 (+20) — fixed in 7.2
- Liferay Portal: before 7.4.3.4 — fixed in 7.4.3.4
How to fix
Upgrade to a fixed version: Liferay Digital Experience Platform 7.2; Liferay Portal 7.4.3.4. Check the vendor advisory for mitigations.
References
- https://liferay.dev/portal/security/known-vulnerabilities/-/asset_publisher/jekt/content/cve-2024-25152
- https://liferay.dev/portal/security/known-vulnerabilities/-/asset_publisher/jekt/content/cve-2024-25152
Get alerted when CVE-2024-25152 or the next vulnerability affects your stack