What’s Vulnerable › Vulnerabilities
CVE-2024-2538: Permalink Manager <= 2.4.3.1 - Missing Authorization to Authenticated(Author+) Arbitrary Post Slug Modification
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-20 · updated 2026-06-17
- Weakness: CWE-639
Description
The Permalink Manager Lite plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'ajax_save_permalink' function in all versions up to, and including, 2.4.3.1. This makes it possible for authenticated attackers, with author access and above, to modify the permalinks of arbitrary posts.
Affected products
- mbis Permalink Manager Lite: before 2.4.3.2 — fixed in 2.4.3.2
How to fix
Upgrade to a fixed version: mbis Permalink Manager Lite 2.4.3.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Xib3rR4dAr/b1eec00e844932c6f2f30a63024b404e
- https://plugins.trac.wordpress.org/changeset/3052848#file35
- https://www.wordfence.com/threat-intel/vulnerabilities/id/70cd028d-122d-4e3c-ac09-150dec07a2cd?source=cve
- https://gist.github.com/Xib3rR4dAr/b1eec00e844932c6f2f30a63024b404e
- https://plugins.trac.wordpress.org/changeset/3052848#file35
- https://www.wordfence.com/threat-intel/vulnerabilities/id/70cd028d-122d-4e3c-ac09-150dec07a2cd?source=cve
Get alerted when CVE-2024-2538 or the next vulnerability affects your stack