What’s Vulnerable › Vulnerabilities
CVE-2024-25412
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in Flatpress v1.3 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the email field.
Affected products
- flatpressblog/flatpress: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: flatpressblog/flatpress 1.3. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1GBL-iY5ZRaxRqLVqpBe1w6dVgEfywAG7/view?usp=sharing
- https://github.com/paragbagul111/CVE-2024-25412
Get alerted when CVE-2024-25412 or the next vulnerability affects your stack