What’s Vulnerable › Vulnerabilities
CVE-2024-2543: Plugin Permalink <= 2.4.3.1 - Missing Authorization via get_uri_editor
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-639
Description
The Permalink Manager Lite plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'get_uri_editor' function in all versions up to, and including, 2.4.3.1. This makes it possible for unauthenticated attackers to view the permalinks of all posts.
Affected products
- mbis Permalink Manager Lite: before 2.4.3.2 — fixed in 2.4.3.2
How to fix
Upgrade to a fixed version: mbis Permalink Manager Lite 2.4.3.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Xib3rR4dAr/a248426dfee107c6fda08e80f98fa894
- https://plugins.trac.wordpress.org/changeset/3053899/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/74f6bf42-3406-47c5-b255-6cc1e8084fb5?source=cve
- https://gist.github.com/Xib3rR4dAr/a248426dfee107c6fda08e80f98fa894
- https://plugins.trac.wordpress.org/changeset/3053899/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/74f6bf42-3406-47c5-b255-6cc1e8084fb5?source=cve
Get alerted when CVE-2024-2543 or the next vulnerability affects your stack