What’s Vulnerable › Vulnerabilities
CVE-2024-25431
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-08 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue in bytecodealliance wasm-micro-runtime before v.b3f728c and fixed in commit 06df58f allows a remote attacker to escalate privileges via a crafted file to the check_was_abi_compatibility function.
Affected products
- bytecodealliance wasm-micro-runtime: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: bytecodealliance wasm-micro-runtime 1.3.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/haruki3hhh/bd228e6dcaf8c18140e1074964912b39
- https://github.com/bytecodealliance/wasm-micro-runtime/issues/3122
- https://github.com/bytecodealliance/wasm-micro-runtime/pull/3126
Get alerted when CVE-2024-25431 or the next vulnerability affects your stack