What’s Vulnerable › Vulnerabilities
CVE-2024-2552: PAN-OS: Arbitrary File Delete Vulnerability in the Command Line Interface (CLI)
- Severity: medium (CVSS 6.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-22
Description
A command injection vulnerability in Palo Alto Networks PAN-OS software enables an authenticated administrator to bypass system restrictions in the management plane and delete files on the firewall.
Affected products
- Palo Alto Networks PAN-OS: from 10.2.0 before 10.2.7; from 11.0.0 before 11.0.6; from 11.1.0 before 11.1.4; from 11.2.0 before 11.2.4; 10.2.7-h1, 10.2.7-h12, 10.2.7-h16, 10.2.7-h18, 10.2.7-h19, 10.2.7-h3 (+26); 10.2.7, 10.2.8, 10.2.9, 10.2.10, 10.2.11, 11.1.4 — fixed in 10.2.7, 11.0.6, 11.1.4, 11.2.4
- Palo Alto Networks PAN-OS: from 11.2.0 before 11.2.4; from 11.1.0 before 11.1.5; from 11.0.0 before 11.0.6; from 10.2.0 before 10.2.12 — fixed in 11.2.4, 11.1.5, 11.0.6, 10.2.12
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.2.7, 11.0.6, 11.1.4, 11.2.4; Palo Alto Networks PAN-OS 11.2.4, 11.1.5, 11.0.6, 10.2.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-2552 or the next vulnerability affects your stack