What’s Vulnerable › Vulnerabilities
CVE-2024-25572
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-11 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-site request forgery (CSRF) vulnerability exists in Ninja Forms prior to 3.4.31. If a website administrator views a malicious page while logging in, unintended operations may be performed.
Affected products
- kstover Ninja Forms – The Contact Form Builder That Grows With You: before 3.4.31 — fixed in 3.4.31
How to fix
Upgrade to a fixed version: kstover Ninja Forms – The Contact Form Builder That Grows With You 3.4.31. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/jp/JVN50361500/
- https://ninjaforms.com/
- https://wordpress.org/plugins/ninja-forms/
- https://jvn.jp/en/jp/JVN50361500/
- https://ninjaforms.com/
- https://wordpress.org/plugins/ninja-forms/
Get alerted when CVE-2024-25572 or the next vulnerability affects your stack